DXX-Rebirth Compatibility?

Everything around the Descent level editor

Moderators: Frustikus, Aus-RED-5

User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Tue Oct 26, 2010 7:14 am

Hi Volfram,

Please regard: One bug per ticket, one ticket per bug.
Volfram
Posts: 4
Joined: Tue Oct 26, 2010 3:03 am

Postby Volfram » Tue Oct 26, 2010 3:21 pm

Sirius wrote:Wha... does nobody ever use the keypad shortcuts for this? The thought of doing serious work by chain-clicking buttons makes my mind boggle... and entering in co-ordinates manually, I'm really surprised you didn't just give up on level editing for being too time-consuming if that's what you were doing beforehand.

THERE ARE KEYBOARD SHORTCUTS!? I noticed the little numbers in the corners of the editor panel(I have been using the arrow keys to navigate my mine), but when I tried pushing those keys, I didn't see anything. Honestly, the chain-clicking's not that bad(not for what I'm currently trying to do, anyway), but manual point entry would be a lot faster(and in fact, unless there are certain tools which I have not been led to believe exist, it's probably the fastest way for me to work when setting major rooms). It's not bad, really. I still expect the texture design, cube settings, and object placement to take more than geometry design. I just thought it was limitations do to the editor being based on DMB.

[edit] Manual has been scanned in and uploaded by Weyrman(apparently), and can be found here. I am reading it now.[/edit]

I mean, I'm not trying to be a jerk about this - I'm just surprised that it seems everyone who talks about it is doing Descent level editing the slow way... maybe there's just a lack of visibility, discoverability, nobody ever (ever - probably true, too) reads the manual... maybe I should post a poll on DBB to find out... :)

well I did read through all of the pages in this pageset, but some of them may need a small update with what I hear are newer versions. got a look in the original DMB1 manual several ages ago, but it was a copy belonging to one of my brother's friends. If there's a full manual out there somewhere, especially if it has a tutorial or two on some of the rules, I'd love to see it.

P.S. Quickest way to find out if bug tickets for issues exist is to look for them on sourceforge.net. You don't even need an account to do that.

That occurred to me not more than five minutes after my post... :oops:


Pumo wrote:I think you can post tickets of your 3 issues with no problems, as most likely they are related to the new version of DLE-XP,
As version 1.8 had a complete code overhaul so there's a lot of new bugs that needs to be covered.

Oh, yeah, and you don't need to have D2X-XL installed for DLE-XP to work (even if you only have the original 1.2 DOS version it should work right).

So feel free to post your bug tickets on the sourceforge tracker. :)

The nonexistent walls and game-crashing occurred in versions 1.8.22 and 1.8.30. The crashing on manual point entry occurred in 1.8.22 only, so it probably got fixed in the interim somewhere. I'll look at the bug tracker.

I had expected that D2X-XL might work better with levels created by the tool developed by the same person/group, but honestly, all I was really after was a no-hassle experience that got me in and playing the game as quickly as possible. DXX-Rebirth did this, D2X-XL didn't. I'm currently running the most recent version of DXX-Rebirth as of about 3 weeks ago(perhaps I should check if he's released any new builds). I'm not sure which "original" Descent version this corresponds with. I thought it might be 1.0, but obviously, this isn't the place to ask such things.

While I can reproduce all three issues fairly reliably, it's a toss-up as to whether the "no-walls" bug or the "crashout" bug will be replicated at any given time when using the Curve generator, particularly since the latter is probably a collection of several smaller glitches. I'd like to get a bit more predictability in that before posting a ticket.
Last edited by Volfram on Tue Oct 26, 2010 9:57 pm, edited 1 time in total.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Tue Oct 26, 2010 4:28 pm

Please point out flaws or obmissions in the DLE-XP online pages in a bug report. Multiple issues per report allowed here - please structure them by topic (segments/walls/triggers/... )

I am maintaining a worklog (find the link on the home page www.descent2.de) where you can find a pretty recent article about my rewriting DLE-XP.
Volfram
Posts: 4
Joined: Tue Oct 26, 2010 3:03 am

Postby Volfram » Tue Oct 26, 2010 8:28 pm

Went to post bug reports and found out that I couldn't reproduce the errors as reliably as I'd thought. Also found where someone uploaded the original DMB2 manual, so I'll be trying to read up and determine what is and isn't a bug before I go posting at random.

I checked the SourceForge file library and didn't find one: Is there a way to get my hands on one of the DLE-XP 1.7.XX builds so I can see what's changed?(I'm assuming the 1.7 builds were more or less stable, as people have obviously made a lot of maps with the program, but I can't really be sure without messing with it.)

Perhaps there's a more appropriate place to post. The following notes are primarily for my own benefit but I'm also partly asking if anyone else has seen them?

direct vertex editing now acts... strangely. Sometimes, it tries to edit vertexes from the "other selection" cube, sometimes it tries to edit vertexes from a cube which is not selected. I'll want to examine this more before creating a report.(IE figure out if there's any predictable pattern to it)

Tried to reproduce the invisible walls bug with 1.8.30, got a crashout instead. I can't seem to get Descent 2 to load any maps with invisible walls anymore.(I suppose you could consider this an improvement) Using the "Diagnostics" tab indicated that cube connections were odd(mostly "Child does not connect to parent cube"), but I don't think I'm familiar enough with the level format to draw any real conclusions about this yet. Again, I suspect locating a 1.7.xx version might be helpful.

Speaking of the Diagnostics tab, I see a checkbox for "automatically fix errors," but there doesn't seem to be any manual control for this. Is there one?

Several of the commands seem to not do what I expect them to do. Again, I'd like to compare to an earlier version where they presumably worked.

I'll post bug reports when I'm sure I know what to put in them. Until then, I doubt they'd be very helpful.
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1434
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Tue Oct 26, 2010 9:42 pm

If you need an earlier version i've got some on my archive.
I can send it to your mail if you wish.
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
Volfram
Posts: 4
Joined: Tue Oct 26, 2010 3:03 am

Postby Volfram » Tue Oct 26, 2010 9:48 pm

That would be wonderful, thanks.

lonewolf325 [at] gmail.com
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1434
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Fri Oct 29, 2010 3:02 am

OK, version 1.7.80 sent. :)
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Re: DXX-Rebirth Compatibility?

Postby Xfing » Fri Feb 22, 2013 1:22 pm

I wanted to make a separate thread for this, but this one seems fine to post the problem in:

DLE seems to corrupt ANY custom map when I convert it to Vertigo. Even though I do have Vertigo and Rebirth can play the Vertigo mission itself with no problems at all, any custom level converted to Vertigo will not run on Rebirth. Upon choosing the level from the menu, Rebirth simply exits and no error message is given.

Do you think this is a DLE problem or a Rebirth problem?
Sirius
Posts: 1987
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Re: DXX-Rebirth Compatibility?

Postby Sirius » Fri Feb 22, 2013 4:47 pm

Well, if Rebirth won't open Descent 2: Vertigo, then it's Rebirth. If it will, then it's probably DLE. (Probably. :))
Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Re: DXX-Rebirth Compatibility?

Postby Xfing » Fri Feb 22, 2013 5:42 pm

It does play the normal Vertigo mission with no hitches.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Re: DXX-Rebirth Compatibility?

Postby karx11erx » Fri Feb 22, 2013 5:49 pm

I cannot help with Rebirth problems, even if they may be rooted in something DLE does, since I have no way to debug Rebirth and find out what makes it crash. You need to ask Zico for help and come back to me with whatever flaw in DLE generated Vertigo conversions he may detect.
Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Re: DXX-Rebirth Compatibility?

Postby Xfing » Fri Feb 22, 2013 7:30 pm

karx11erx wrote:I cannot help with Rebirth problems, even if they may be rooted in something DLE does, since I have no way to debug Rebirth and find out what makes it crash. You need to ask Zico for help and come back to me with whatever flaw in DLE generated Vertigo conversions he may detect.


Yeah, I already sent him an e-mail. I'm afraid the problem may be something I did, since I think that long ago Rebirth used to run my custom Vertigo missions just fine. I have, however, since updated both my DLE and Rebirth, with new .ini files, and the problem persists. Well, we'll see what the issue is this time.

Return to “DLE-XP Help”

Who is online

Users browsing this forum: No registered users and 1 guest