Several textures not displaying?

Everything around the Descent level editor

Moderators: Frustikus, Aus-RED-5

Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Several textures not displaying?

Postby Xfing » Tue Jul 23, 2013 10:50 pm

While browsing through the game exclusive texture folders I compiled, I have noticed that there are several that are present in the PIG files (Obviously, I had to extract them from somewhere with DTX2), but don't display in the texture choice menu. I have no idea whether this has something to do with some flag on those textures or the editor itself. Nevertheless, here's the list of the textures.

Image

The first one is animated. Noticeably, all of those textures are rather D1 in style. Could they have been scrapped by the dev team but left in the PIG files out of haste?
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1434
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Re: Several textures not displaying?

Postby Pumo » Wed Jul 24, 2013 12:44 am

Those textures are not level textures, are object textures and are used to texture some reactors and the ship, that's why DLE doesn't includes them on the list as those are not designed to be used as walls.

But if you already extracted them you can use them for walls by adding them as custom ones. :)
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
Sirius
Posts: 1987
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Re: Several textures not displaying?

Postby Sirius » Wed Jul 24, 2013 4:57 am

While investigating something else I had a look at how DLE stores texture indices in levels recently, and I know the explanation for this. Basically: there is some kind of mapping that D2 performs, probably with the help of the PIG, for which texture index maps to which texture. DLE includes everything that D2 considers a valid index already; the reason these textures aren't in the list is that there are no texture indices that map to them.

This is the same reason you can't pick an individual frame of an animated monitor texture to display on a wall - it's the whole animation or nothing.
Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Re: Several textures not displaying?

Postby Xfing » Wed Jul 24, 2013 11:45 am

Oh, I get it. Thanks for the explanation.

Still, being able to access single frames of animations would be a sweet feature for DLE. I even posted a ticket suggesting it some time ago. You only really have access to animated door frames in DLE, plus some stuff like perhaps flowing lava or water. And this creates difficulties if you would like to swap the frames for something else, kinda like I sacrificed that orange secret door (like the one leading to the Vulcan cache in D2 lvl 2) for the green, cobblestone one from D1. Both doors had 7 frames, so it was easy enough to replace. But to do D1 monitors, the D1 lava trickle and stuff like that, I need DTX2. Can something be done?
Sirius
Posts: 1987
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Re: Several textures not displaying?

Postby Sirius » Wed Jul 24, 2013 3:55 pm

It can (not trivial but possible somehow), but I still am not sure whether it should... where do you stop? Should it be able to replace robot textures as well?
If DTX/DTX2 are no longer an option (e.g. they stop working), things change a bit.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Re: Several textures not displaying?

Postby karx11erx » Wed Jul 24, 2013 6:58 pm

All those old Win9x/ME rooted programs (DTX, HXMEdit, etc.) stopped working for me under Win7 (even when trying compatibility mode). I have Win7 ultimate, but I am not gonna install the virtual XP environment just for these.
Sirius
Posts: 1987
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Re: Several textures not displaying?

Postby Sirius » Thu Jul 25, 2013 4:46 am

...that is exactly how I run DTX :oops:
I'm told that there is no more Windows XP Mode in Win8; it might be possible to get it to run under the client Hyper-V instance if you have a separate copy, though. Still, that sort of thing is why it's seeming a bit more compelling to replicate DTX's features; system setups that can run it are slowly getting nearly as rare as those that can run D2-3DFX. And I'm not really sure whether we'll get the Win9x answer to DOSBox anytime soon... there's a legitimate need for one but a lot of politics to sort out first.

Well, I can try to figure out a solution, it'll likely be a big project if it's to have any real point though. I figure Diedel's too busy with Oculus Rift support to want to touch this one with a barge pole. :mrgreen:
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Re: Several textures not displaying?

Postby karx11erx » Thu Jul 25, 2013 1:07 pm

I am not busy with the Rift support. All the code I could do for it w/o having the actual hardware is done, and the hardware will only arrive somewhere in August (or maybe even later).

I will be on vacation the next three weeks though. :clap:
Sirius
Posts: 1987
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Re: Several textures not displaying?

Postby Sirius » Thu Jul 25, 2013 5:10 pm

OK have fun!
Xfing
Posts: 29
Joined: Mon Jan 30, 2012 11:07 pm

Re: Several textures not displaying?

Postby Xfing » Thu Jul 25, 2013 9:56 pm

Yeah, enjoy the break!

BTW, I have a Vista Home on my laptop and all those programs work fine. Still, its a bitch to have to use DTX2 to replace animated textures. It's very useful for extracting the files, though.

Return to “DLE-XP Help”

Who is online

Users browsing this forum: No registered users and 1 guest