D2X-XL V1.14 BETA

All other topics around Descent and D2X-XL

Moderators: Frustikus, simX, Aus-RED-5

User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sun Feb 08, 2009 12:38 am

Oh my. I think I could finally get rid of sound distortion and even far and wide remove the popping at the start and end of low res sounds.

Edit: Flare bug fixed too. Sykes' player profile lead me to the bug and the solution.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

D2X-XL v1.14 Beta 14 Available

Postby karx11erx » Sun Feb 08, 2009 1:41 am

Sound issues hopefully fixed or at least significantly diminished. Popping at start and end of sounds as good as removed. You should use hires sounds anyway. :P

Flare bug finally fixed.

CTD due to too long HUD messages fixed (error message goes to log file instead). The long messages issue hasn't been fixed yet, but shouldn't hurt that badly anymore.

Automap issue still open.

Now it's idiotically late again, my head is hurting, and I have ruined half of my weekend with this. I hope I am through with this soon. I had planned to be done with v1.14 four weeks ago. It's not fun anymore. :wallbash:
Last edited by karx11erx on Tue Feb 10, 2009 11:59 pm, edited 1 time in total.
User avatar
darkflamewolf
Posts: 690
Joined: Sat Aug 23, 2008 9:14 pm
Location: Minot, ND

Postby darkflamewolf » Sun Feb 08, 2009 4:26 am

We all appreciate what you are doing. Even from those who you don't think appreciate it. :)
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Sun Feb 08, 2009 5:48 am

darkflamewolf wrote:We all appreciate what you are doing


Diedel, take that for sure! :)

I've tested the new Beta14 and this is what i found:

Good news: it seems the sound distortion is finally gone! I've tested with hi-res music and with hi-res sounds and it works perfectly! also the hi-res clicking is gone! Hooray for that! :bounce:

Bad news: Hi-res sounds from mods doesn't gets loaded. I've put my own hi-res sounds on mods/kartsal/sounds and they are ignored (i hear the original sounds from the 'sounds2' folder instead). :(

If you want to do testing, this is the new sounds folder for PM Kartsal, so you'll just need to put it on the mods/kartsal folder:

http://www.goaruna.com/o25

On another issue, I've also got an idea to ger rid of old crappy DTX files and use hi-res sounds with a per-level sounds folder.
I will send you an e-mail with more details about this. ;)

Overall, Beta14 seems pretty sweet! :D
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
darklord42
Posts: 254
Joined: Sat Nov 17, 2007 3:01 am
Contact:

Postby darklord42 » Sun Feb 08, 2009 6:23 am

Still, thankyou so much for all your hard work Diedel. It's not much, but I for one greatly appreciate it. You really have brought life back into a real classic. And I have had many hours of enjoyment playing a modernized D2 and D1 through it. D1 happened to be the first pc game that I have ever owned. It came with the cd starter package bundled with my old Macintosh Performa. As such it holds a special place in my heart. ;) Thank You!
Macbook Pro 6,2
Mac OS. 10.9.3
2.8 GHz Intel i7
8 GB RAM
GeForce GT 340M 512mb/Intel HD Graphics
Intel HD Audio
quadcore

Postby quadcore » Sun Feb 08, 2009 3:44 pm

Noticed some weeks ago, that there is a new beta around. First issues were unstable, but since beta 11 its playable. Great improvement, also loading time much shorter now!
Thanks, Diedel! :D

Now some bugs: With beta 13 sound was gone, but was already discussed and now solved with beta14.
But now with beta 14 and also in beta13 the following problems:
- Per pixel lighting leads to crash at level load, Standard and Vertex Lighting works ok.
- But smoke is gone, neither rockets nor robots produce smoke anymore. Tried to adjust the sliders, but no effect.
- Coronas are also gone, cannot be influenced by sliders.
With beta 11 smoke and coronas worked (don't know about beta 12, missed it)

----- My System ----------
CPU Intel E6750
MB GB G33M DS2R/S2
NVIDIA GeForce 8800GT
4GB RAM
Realtek ALC 889A
Windows XP64 and 32
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Sun Feb 08, 2009 6:19 pm

I'm glad I could be of help, Karx! I hope you get things smoothed out soon.

Also, quadcore, please post those at Sourceforge.net instead of on the forums. It will make Diedel's job much, much easier, as he really can't sort through the bugs on this page. It just frustrates him further.

Here is a direct link to the bug tracker: http://sourceforge.net/tracker/?atid=79 ... unc=browse

It also might help you to look at the current bug reports, and see if any of them match what you are experiencing, so you don't post a bug that's already on there.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sun Feb 08, 2009 8:48 pm

quadcore wrote:- But smoke is gone, neither rockets nor robots produce smoke anymore. Tried to adjust the sliders, but no effect.
- Coronas are also gone, cannot be influenced by sliders.


That happens to people who cannot be bothered to diligently post what I have written here.

Bug reports meant to be processed by me have to go via Sourceforge.net.

You couldn't be bothered to read this forum's rules, could you?
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

D2X-XL v1.14 Beta 15 Available

Postby karx11erx » Wed Feb 11, 2009 12:28 am

Another week, another version ... :P ... and it is - a beta!

Most issues fixed (and D2X-XL loves D1 again) plus quite a few I had found myself. A few couldn't be reproduced here.

Added object triggers for hostages and powerups (DLE-XP has been updated accordingly).

Here is a version of Pumo's demo level in a setup that utilizes D2X-XL's modding support:

http://www.descent2.de/missions/3rdpart ... artsal.rar

Extract to your D2X-XL main folder using subfolders. The mission is ./missions/pumo/kartsal.hog, so you have to browse to the mission subfolder "pumo" to load it.

I have added fading to the menus and message boxes. Enable in d2x.ini with "-fademenus t" where "t is a time in ms (1 / 1000 sec). 100 - 130 look like good values to me.

Have fun. :)

PS: Pumo, I found the sounds in Kartsal to be extremely loud, way louder than the standard D2 hires sounds.
Last edited by karx11erx on Sun Feb 15, 2009 8:11 am, edited 1 time in total.
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Re: D2X-XL v1.14 Beta 15 Available

Postby Pumo » Wed Feb 11, 2009 1:09 am

karx11erx wrote:PS: Pumo, I found the sounds in Kartsal to be extremely loud, way louder than the standard D2 hires sounds.


Mmmh. You're right. Luckily i will re-make many of the sounds from scratch as 44KHz Stereo 16bits (as i have all PM raw sounds files on my HD) and will be less louder. ;)

BTW, i found a small bug on Beta15 regarding ambient looping sounds when pausing and resuming the game and will make a bug ticket on SF.NET ;)
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
Frustikus
D2X-XL Team
D2X-XL Team
Posts: 778
Joined: Mon Oct 22, 2007 3:06 pm
Location: Germany

Re: D2X-XL v1.14 Beta 15 Available

Postby Frustikus » Wed Feb 11, 2009 1:41 am

Pumo wrote:
karx11erx wrote:PS: Pumo, I found the sounds in Kartsal to be extremely loud, way louder than the standard D2 hires sounds.


Mmmh. You're right. Luckily i will re-make many of the sounds from scratch as 44KHz Stereo 16bits (as i have all PM raw sounds files on my HD) and will be less louder. ;)

BTW, i found a small bug on Beta15 regarding ambient looping sounds when pausing and resuming the game and will make a bug ticket on SF.NET ;)


Hi Pumo,

for me it is very important to know, how to get sounds extremely loud without any distortion. How did you make it ?!
Intel Q9550 (E0) @ 3420 MHz and standard voltage with Sonic Tower Rev.2, Geforce GTX 260 (896 MB), Asus P5Q Deluxe, 6 GB GSkill DDR2-1066, 2x500 GB Seagate @ Raid 0, Soundblaster XFi, Sharkoon Rebel12 Case, Teufel Concept Magnum 5:1, Samsung 2494 SW , Genius Navigator 535, Logitech Wingman FF, Windows 7 Ultimate 64 bit
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Wed Feb 11, 2009 1:47 am

Huzzah! Not only another beta, but Pumo's demo! When will the link be up?
User avatar
Weyrman
D2X-XL Expert
D2X-XL Expert
Posts: 579
Joined: Tue Sep 25, 2007 7:47 pm
Location: Brisbane Australia
Contact:

Postby Weyrman » Wed Feb 11, 2009 2:20 am

link for what? Both items are linked in Diedels's last post :roll:
-SYSTEM SPECS-
MBoard:"GigaByte Z68X-UD3H-B3" Motherboard
CPU: Intel i7 E2600 3.40GHz
RAM: 8GB DDR3 2133MHZ
HD: WDC 10EARX 1TB SATA
Video: GigaByte 1G ATI 4890
Monitor: Asus VS428 LCD 24"
Sound: Onboard - now with connected 5.1 sound system
OS: Windows 7 x64 Home Premium
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Wed Feb 11, 2009 2:20 am

I get a 404 on Pumo's demo.
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Wed Feb 11, 2009 2:25 am

Yeap, but it seems the link to my mission i broken. :P

To Frustikus:
The thing i did was to compress the sound in Cool Edit Pro using Dynamics. I think i used a Vocal Compressor (like the ones used on singers).
Sometimes i compress the wave twice. After compression i normalize the wave to 0dB or -0.5dB and voilá! You get loud sounds without distortion :)

BTW, if you don't have Cool Edit you can do the same (use Dynamics) on GoldWave and i suppose also an Audacity, although i haven't checked that.

To Sykes:
I suppose Diedel will notice that the link to Pumo Mines demo is broken tomorrow. ;)

EDIT:
To Diedel: i've checked Beta15 and the new powerup triggers are working perfectly. The only problem is that i've found a bunch of bugs, but i've already reported them on SF.net ;)
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits

Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 6 guests