Sound squelching in 1.14.15, didn't have issue with 1.13

Install & setup problems, application questions and other nasty things ;)

Moderators: Frustikus, simX, Aus-RED-5

User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sun Apr 19, 2009 9:44 am

Sykes,

post your problems on SF.net!
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Sun Apr 19, 2009 6:37 pm

I have, and nobody can find out what's wrong, so I gave up. It's no big deal ;)
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sun Apr 19, 2009 6:39 pm

Oh. :clue:
Thraka
Posts: 50
Joined: Fri Apr 18, 2008 6:07 pm

Postby Thraka » Wed May 06, 2009 3:26 pm

I was able to come back to this, post my out-of-town. I did re-verify that I don't have this problem with 1.13, and I also found out it only happens with Descent 1 levels. Descent 2 levels are fine. Don't know if that helps.
Frustikus
D2X-XL Team
D2X-XL Team
Posts: 778
Joined: Mon Oct 22, 2007 3:06 pm
Location: Germany

Postby Frustikus » Thu May 07, 2009 12:35 am

Download the D1 hires sounds too.
Settings d2x.ini:
-use_d1sounds 1
-sound44k
-hires_sound 2
-sdl_mixer 1

I never had any sound problems with those settings. In the past there was only one bug that caused distorted sound:
http://sourceforge.net/tracker/?func=de ... tid=797586
but this bug is already fixed.
Intel Q9550 (E0) @ 3420 MHz and standard voltage with Sonic Tower Rev.2, Geforce GTX 260 (896 MB), Asus P5Q Deluxe, 6 GB GSkill DDR2-1066, 2x500 GB Seagate @ Raid 0, Soundblaster XFi, Sharkoon Rebel12 Case, Teufel Concept Magnum 5:1, Samsung 2494 SW , Genius Navigator 535, Logitech Wingman FF, Windows 7 Ultimate 64 bit
Thraka
Posts: 50
Joined: Fri Apr 18, 2008 6:07 pm

Postby Thraka » Sat May 09, 2009 5:18 pm

Ok I'll make sure I got the descent 1 hi-res sounds.

Could someone else that has all the source. upload the whole thing somewhere? I hate to ask, but tracking down each individual library then making sure it's all setup is such a pain. I've grabbed the source from sourceforge but it complains about all the dependancy libraries that aren't included.

Or at least is there a place on the site that links to all the different things I need to download and extract\install to make sure I can compile the source? This would help for tracking down crashes I end up running into and ease pain on karx11erx :)
Sirius
Posts: 1990
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Postby Sirius » Sat May 09, 2009 6:28 pm

I think most of the dependencies are SDL related, which is usually not distributed with the source code for applications because different people install it in different places (often somewhere in the compiler directories).
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sat May 09, 2009 7:25 pm

Thraka,

downloading and installing D2X-XL can be done grabbing 6 packages:

D2X-XL distro
Hires textures
Hires models
Hires sounds D2
Hires sounds D1
Level pack

My installation instructions state which libs you need to additionally download and install if you want to build D2X-XL yourself, and the source code of all required libs is hosted by me and you kind find download links for them on the d2x-xl download page (www.descent2.de/d2x.html).

If you are going to build D2X-XL you will have to make sone extra efforts; that absolutely normal for people with that ambition.
Thraka
Posts: 50
Joined: Fri Apr 18, 2008 6:07 pm

Postby Thraka » Sat May 09, 2009 7:40 pm

ahhh ok i always just go to sourceforge for the code. i'll read through your instructions :D

fun note. I was playing multiplayer with my sister and a guy from sweden joined randomly and played few levels hehe. He just got the engine and was enjoying it a lot.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Sat May 09, 2009 8:26 pm

Cool!
Thraka
Posts: 50
Joined: Fri Apr 18, 2008 6:07 pm

Postby Thraka » Sun May 10, 2009 5:09 pm

Ok. Downloading and installing the D1 hi-res sounds fixes the problem. So it seems to only happen when
1) Configured to use D1 hi-res sounds
2) You do not have the hi-res sounds and it defaults to out-of-the-box sounds.

But using hi-res fixes my prob, no biggie anymore :)
User avatar
Red_5
Posts: 401
Joined: Tue Sep 25, 2007 11:34 pm
Location: Somewhere, America
Contact:

Postby Red_5 » Wed Aug 26, 2009 4:58 am

Sorry for the bump... Same problem though...

Just my two cents, it sounds like overload. Backing up this guess is the fact that it occurs when lots of sounds play simultaneously, as previously mentioned.

I'm using the same hires sounds now that I used before 1.14.x without a problem, but now they distort like that when it gets intense...

I wonder if a bit of sound code got messed?
Regards from Red_5

MacBook Pro 13"
2.4GHz dual-core Intel i5 processor
320GB 5400-rpm hard drive
Intel HD Graphics 3000 with 384MB DDR3 SDRAM
4GB 1333MHz DDR3 memory
7 Beautiful Hours of Battery
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Wed Aug 26, 2009 5:00 am

Make sure you have your sound channels configured correctly on D2X-XL.
On the sound and music options (while on the main menu, not ingame) play with the sound channels slider and see if that helps.
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
User avatar
Red_5
Posts: 401
Joined: Tue Sep 25, 2007 11:34 pm
Location: Somewhere, America
Contact:

Postby Red_5 » Wed Aug 26, 2009 10:11 pm

The sounds channels option isn't in the menu anymore. Can I set it with a command line?
Regards from Red_5

MacBook Pro 13"
2.4GHz dual-core Intel i5 processor
320GB 5400-rpm hard drive
Intel HD Graphics 3000 with 384MB DDR3 SDRAM
4GB 1333MHz DDR3 memory
7 Beautiful Hours of Battery

Return to “D2X-XL Help”

Who is online

Users browsing this forum: No registered users and 3 guests