BUG hunting thread

Install & setup problems, application questions and other nasty things ;)

Moderators: Frustikus, simX, Aus-RED-5

Yutoma

Postby Yutoma » Wed Jul 29, 2009 2:59 pm

Ionospherenegate wrote:
Anyway, on version 1.14.71 it crashes after killing any robot on -pured2,


I am getting that same problem too.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Wed Jul 29, 2009 3:03 pm

Crash will be fixed in next version. Texture problem not yet reproducable here.
Ionospherenegate
Posts: 14
Joined: Wed Jul 29, 2009 2:31 pm

Postby Ionospherenegate » Wed Jul 29, 2009 3:46 pm

yeah guess the texture stuff stopped.

EDIT: oh yeah and the new ver. pauses sometimes and my ship comes out crazy afterwords
Life is like Descent, you defeat enemies, get stronger along the way, you earn extra chances, you can clear out a "safe" zone you can go back to, you have a place to "re-fuel," after each goal you can get out before it blows up in your face, there is a big challenge that fights you every so often, and at then end you get so see the credits... if your a good boy. ("WHO'S YER DADDY?")
:MB:Intel 82801 PCI Bridge 244E :OS:Windows XP Home SP3:TWR:IDK IDC HS:2" inward, 5" fan outward :CPU:Intel C2D E4700 2.6 GHz RAM:Crucial 1 GB X2 :HDD:ATA WDC WD800JB-22JA0 80 GB :VC:PCIE2 HIS Radon 1650X 512 MB DDR2 EVGA :SC:5.1 SBLive! Creative EAX2 3D :CD:Sony DVD RW DRU-190A :FLPY:3.5" 1.44 MB :KB:MicroInv KB565BL w/ fellowess :MSE:Logitech Laser 5 button :SPKRS:JUSTer 80 Watt
Irontower
Posts: 150
Joined: Sat Apr 04, 2009 7:06 pm

no sound when reloading a D1 savegame

Postby Irontower » Wed Jul 29, 2009 6:22 pm

I get no sound when reloading a D1 savegame after a new start from D2x-xl v1.14.71 (D2-savegames are working). I'm not sure if this is a bug because my Pc is a little crazy after updating to 4Gb ram. My X-Fi makes no beep anymore so I changed to an Asus D1 wich works perfectly. Has anyone else this problem?
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Wed Jul 29, 2009 6:30 pm

My X-Fi stopped working yesterday too. I can't remember having changed anything on my system though.
Irontower
Posts: 150
Joined: Sat Apr 04, 2009 7:06 pm

Postby Irontower » Wed Jul 29, 2009 6:48 pm

my X-Fi extrem music died two times under garantie....
In my DOS-PC my AWE64 is working since many years, also the SB-Live in my 3Dfx machine, never any problem !
Sirius
Posts: 1990
Joined: Tue Sep 25, 2007 10:29 pm
Location: Bellevue, WA
Contact:

Postby Sirius » Thu Jul 30, 2009 2:34 am

And to think I just had an X-Fi arrive. :( (Been waiting two months for it as well...) Here's hoping I get better luck with it.
Ionospherenegate
Posts: 14
Joined: Wed Jul 29, 2009 2:31 pm

Postby Ionospherenegate » Fri Jul 31, 2009 3:35 am

IT HAPPENED AGAIN BUT I HAVE PROOF THIS TIME
Image
also in this screeny, its not a game error but a problem with the highrez switch image file
Image
in THESES TWO screenies as you cannot see i don't know if its the transparency system or the image is printed on the object front and back, it doesn't do it all the appearing grates, but it does do it ALL THE TIME to the ones it DOES.
Image
now you don't see it
Image
now you do



sigh... imageshack is too slow and photobucket has adds coming out of its butt
(i have a bandwith of 100 kbps don't think its my service)
Life is like Descent, you defeat enemies, get stronger along the way, you earn extra chances, you can clear out a "safe" zone you can go back to, you have a place to "re-fuel," after each goal you can get out before it blows up in your face, there is a big challenge that fights you every so often, and at then end you get so see the credits... if your a good boy. ("WHO'S YER DADDY?")

:MB:Intel 82801 PCI Bridge 244E :OS:Windows XP Home SP3:TWR:IDK IDC HS:2" inward, 5" fan outward :CPU:Intel C2D E4700 2.6 GHz RAM:Crucial 1 GB X2 :HDD:ATA WDC WD800JB-22JA0 80 GB :VC:PCIE2 HIS Radon 1650X 512 MB DDR2 EVGA :SC:5.1 SBLive! Creative EAX2 3D :CD:Sony DVD RW DRU-190A :FLPY:3.5" 1.44 MB :KB:MicroInv KB565BL w/ fellowess :MSE:Logitech Laser 5 button :SPKRS:JUSTer 80 Watt
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jul 31, 2009 7:05 am

Il always wonder why people take "I cannot reproduce it" as "I do not believe you".

Problems do always not appear with every D2X-XL installation and often aren't reliably reproducable. Until they are for me, I cannot fix them.

I do not know whether you read the forum stickies (probably not), but I only work on bugs that have been reported to me via Sourceforge.net. So if you expect some forum member to help you with this, fine. If you want me to help, you're wrong here. Btw, if you report it there post in the tracker item that has been made for this problem, because it has been reported there already, and don't make a new entry - because I would delete that one as double, and you'd be all angry about me although you had no reason to.
Frustikus
D2X-XL Team
D2X-XL Team
Posts: 778
Joined: Mon Oct 22, 2007 3:06 pm
Location: Germany

Re: no sound when reloading a D1 savegame

Postby Frustikus » Fri Jul 31, 2009 7:23 am

Irontower wrote:I get no sound when reloading a D1 savegame after a new start from D2x-xl v1.14.71 (D2-savegames are working). I'm not sure if this is a bug because my Pc is a little crazy after updating to 4Gb ram. My X-Fi makes no beep anymore so I changed to an Asus D1 wich works perfectly. Has anyone else this problem?


There is a bug in the driver (or firmware) with XFi and 4 GB RAM. Download and install the latest driver for the XFi and if this won´t fix the problem, look for a better firmware for that card. There was an option to write an email to creative and then you´ll get a better firmware from creative for that soundcard too.
Intel Q9550 (E0) @ 3420 MHz and standard voltage with Sonic Tower Rev.2, Geforce GTX 260 (896 MB), Asus P5Q Deluxe, 6 GB GSkill DDR2-1066, 2x500 GB Seagate @ Raid 0, Soundblaster XFi, Sharkoon Rebel12 Case, Teufel Concept Magnum 5:1, Samsung 2494 SW , Genius Navigator 535, Logitech Wingman FF, Windows 7 Ultimate 64 bit
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jul 31, 2009 8:26 am

Well, I am having 4 GB RAM (my WinXP only using 3 GB though), and the card was working fine. A few days ago it started to emit a low pitched humming, and when I unplugged my speakers and plugged them back in, I had no sound at all anymore. I tried all sound channels, tried the headphones too to make sure it wasn't the speakers, but it's the card. Both speakers and headphones work fine with integrated sound. I have been using the latest X-Fi drivers already.
Ionospherenegate
Posts: 14
Joined: Wed Jul 29, 2009 2:31 pm

Postby Ionospherenegate » Fri Jul 31, 2009 6:05 pm

i didn't think you didn't believe me, but i had no images the last time]

EDIT: The AI is not like D2... I was RIGHT BEHIND a bulk destroyer WITH my headlight ON and it couldn't sense me, also the water boss can't teleport worth junk making him easy pickings, and the guide bot can't find you worth junk.

also when I fire the helix the area around the shot takes ONLY the light coming from the helix shots and i tried this on multiple settings and still the same results, same with the flare, the reactor's cannon, and some other weapons that i don't feel like making sure if they do or not

also the explosions pass through closed doors.
Life is like Descent, you defeat enemies, get stronger along the way, you earn extra chances, you can clear out a "safe" zone you can go back to, you have a place to "re-fuel," after each goal you can get out before it blows up in your face, there is a big challenge that fights you every so often, and at then end you get so see the credits... if your a good boy. ("WHO'S YER DADDY?")

:MB:Intel 82801 PCI Bridge 244E :OS:Windows XP Home SP3:TWR:IDK IDC HS:2" inward, 5" fan outward :CPU:Intel C2D E4700 2.6 GHz RAM:Crucial 1 GB X2 :HDD:ATA WDC WD800JB-22JA0 80 GB :VC:PCIE2 HIS Radon 1650X 512 MB DDR2 EVGA :SC:5.1 SBLive! Creative EAX2 3D :CD:Sony DVD RW DRU-190A :FLPY:3.5" 1.44 MB :KB:MicroInv KB565BL w/ fellowess :MSE:Logitech Laser 5 button :SPKRS:JUSTer 80 Watt
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jul 31, 2009 8:20 pm

May I ask why you don't have the courtesy to report this via the trackers on SF.net, one ticket per issue?
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Fri Jul 31, 2009 8:22 pm

Test if all those issues still happens using the Default player profile (the one that comes on D2X-XL RAR)

You may have a lot of issues if you're using an old pilot profile, i recommend you to create either a new one on D2X-XL or using the Default profile modified to your needs.

(And Karx is right, the best to post your issues on SF.net tracker, as here on the forum is easy to lose track of bugs and he can't have control of them)
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jul 31, 2009 9:42 pm

Re the headlight: A bulk destroyer doesn't notice a player behind it with headlight on in D2X-Rebirth 0.55.1 and D2X-W32 1.6 as well. I just tested it with both programs and a small test level I have built for the purpose.

Next time before you make such claims verify them with the original Descent 2, d2_3dfx or D2X-Rebirth if you cannot run any of the others.

Return to “D2X-XL Help”

Who is online

Users browsing this forum: No registered users and 5 guests