3 goes and I'm out

Install & setup problems, application questions and other nasty things ;)

Moderators: Frustikus, simX, Aus-RED-5

Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

3 goes and I'm out

Postby Radar » Thu Nov 29, 2007 2:08 pm

I've read a lot of posts but can't find anything even similar to a problem I've got.
I've installed everything, D2x and Descent 2 (patched) and Descent 1(patched) to two PC's now and got the same result both times, the only common factor being me!

Everything installs fine, all the files in the right place. ( I read the instructions)
I can then run D2X twice with no problems.
The third and all subsequent launches, I get a black screen, it appears as if everything is working underneath, as all the sounds are there, and from the main menu (you can tell from the sound track) up once and enter exits the game.

I have re-copied everything, and it makes no difference I still get a black screen.
I've deleted everything, re-started and still just a black screen.

It looks like it's something in the OS, but I can't find any reference to D2X in the registry.

Any help please?

OS is Windows XP SP2
Both PC's have Nvidia cards (4MX and 8600)

Thank You

Radar

Appologies if this is in the wrong place, just point to where I should be.
-JoFFa-
Posts: 612
Joined: Sat Sep 29, 2007 2:12 pm

Postby -JoFFa- » Thu Nov 29, 2007 2:50 pm

Man - here goes - you're gonna get it! 8)
Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

Postby Radar » Thu Nov 29, 2007 3:10 pm

I'm half expecting to get a grumpy, your looking in the wrong place / read the manual.

But I had to start somewhere.

Unless you meant I'm going to get the answer I'm after (don't think thats what you meant though)
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Thu Nov 29, 2007 3:24 pm

You could file a support request on Sourceforge.net.

What program version?

I find it very provocative writing to "half expect a grumpy reply". Do you want one?
-JoFFa-
Posts: 612
Joined: Sat Sep 29, 2007 2:12 pm

Postby -JoFFa- » Thu Nov 29, 2007 8:14 pm

karx11erx wrote:I find it very provocative writing to "half expect a grumpy reply". Do you want one?



heh-heh-heh. I just love you guys.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Nov 30, 2007 6:09 pm

Does it work again after logging out and back in, or rebooting?

Run d2x-xl with -printlog parameter and post the resulting d2x.log in a support request ticket on Sourceforge.net please.

It's ok to post such problems here, and forum members can probably help you, but I require people to use the D2X-XL trackers on Sourceforge.net, simply for better organisation.
Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

Postby Radar » Sat Dec 01, 2007 10:33 am

My main reason for posting here first was inc ase anyone else had encountered this problem and could just tell me how big a muppet I am and this is how to fix it.

Looks like no one else has this problem so I'll grab the logs and head over to source forge.

In answer to the couple of questions. Version: latest off this website, and log out and back in; makes no difference, and neither does rebooting.

I have found one way of fixing this, it's just not practical. PC number 2 is a dual screen set up. If I run in windowed mode, and launch onto screen 1, I get a black screen, if I move the window to screen 2, all is well. Move it back to screen 1 and it goes black again.
I had a quick try diabling one or other of the screens, and all I got was black. I had to have two screen and move from one to the other.

Thank you for the help, I'm off collecting logs now, and then to sourceforge.

Radar

PS. The remark about the grumpy reply. I tried to be polite and not demand fixes as some others do, but I'm never sure if how I type things conveys how I meant to say them. I'm seriously impressed with the work that has been done, and can't wait to get the thing working on my setup, and I know what it's like when you do something for the love of it, not for the money.(and I know what it feels like when others demand you fix this stuff)
User avatar
Aus-RED-5
Forum Moderator
Posts: 1490
Joined: Tue Sep 25, 2007 9:02 am
Location: Adelaide, South Australia
Contact:

Postby Aus-RED-5 » Sat Dec 01, 2007 11:43 am

Radar wrote:In answer to the couple of questions. Version: latest off this website, .......

hehe - that tells us what?

You do realize that D2X-XL gets updated almost everyday? Sometimes 2 times a day.
----------(The Windows Versions does)-----------

It's always a good idea to tell us the version number you have. ;)
----System Specs----
Case: Corsair Obsidian 650D Black
Motherboard: ASUS Sabertooth X58
CPU: Intel Core i7 960 3.20ghz
Heat Sink: Corsair H100 CPU Water Cooler
Memory: Corsair 6GB (3 x 2048mb) DDR3 1600 Dominator (PC12800 - TR3X6G1600C8D)
Video Card: ATi SAPPHIRE Radeon HD 7970 3GB GDDR5 OC Edition
Hard Drives: SSD Corsair Force Series 3 F120 120GB & WD5003ABYX Enterprise RE4 500GB
Media Player: LG BH10LS30 BluRay Burner
Power Supply: Corsair HX-850
OS: Windows 7 Pro 64Bit
Monitor: Benq XL2420T LED
Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

Postby Radar » Tue Dec 04, 2007 3:55 pm

An update, of sorts.

Of the two trouble machines, one is now working, I updated D2X-XL to Monday mornings version, and it all apperas to be working fine.

THe second machine is still being awkward. However after trying various things and various searches I stumbled across some posts on Nvidia forums complaining that the last drivers for the gfx card I've got don't support open GL, you just get a black screen.

It is an old PC, with old hardware, and old drivers, so I'll dig out a slightly better gfx card and see what happens.
(Nforce2 main board with integrated GeForce4MX if anyone is really interested)

Radar
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Tue Dec 04, 2007 6:37 pm

Integrated gfx and D2X-XL don't go together well.

"Three goes and I'm out".

Looks like it's not D2X-XL's fault, though your thread title somehow suggests it to me.
Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

Postby Radar » Wed Dec 05, 2007 10:03 am

It looks like the main issue is the gfx card. I just found it strange that everything ran fine the first two times. To me this meant it was software not hardware. I was right, it was a software issue. I just foolishly expected Nvidia's drivers to work as they are supposed to.

I've learned my lesson. (just cos they make lots of money and do it for a living doesn't mean they do it right, and the ones doing it for fun do a better job)

I have to say that the things I can make the 4MX card do with D2X-XL are quite funny. launch the app on screen 1, black screen, move it to screen 2, all works. Drag it back so it's half and half screen 1 and screen 2, works fine. move it so the last tiny bit of the window is still on screen 2, the rest on screen 1, works fine. Move it that last little bit, so everything is on screen 1, blackness. I'm not sure you could program that into the driver even if you tried.

Radar
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Wed Dec 05, 2007 11:49 am

So you are suggesting I programmed it into D2X-XL, right?

It is pretty obvious that this is a driver issue, and as soon as all output goes to screen one, it's redirected somewhere.

Stop trying to blame me for this.
Radar
Posts: 6
Joined: Thu Nov 29, 2007 1:55 pm

Postby Radar » Wed Dec 05, 2007 1:44 pm

no, not at all.

Now I've found out what is happening it's easy to look back and think yes it was obviously a driver issue from the start.

My comment about it being included in the code was aimed at Nvidia not you.

My coding skills stop at 8-bit micro controllers, so what you have done getting the original data files to run at a higher res, and add more effects is seriously impressive.

I think the only person to blame in this is me.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Wed Dec 05, 2007 2:16 pm

I don't think at all that you are to be blamed for driver problems.

It's just - if something's driving you mad, the better way is to take your time to chill out, then start to ask for help (speaking from experience here ;)).

Return to “D2X-XL Help”

Who is online

Users browsing this forum: No registered users and 2 guests