Page 1 of 2

Can't upgrade Descent 2

Posted: Mon Mar 31, 2008 7:35 pm
by Alter-Fox
I'm running a no-cd crack on D2, as I can't find the CD. Unfortunately, this means I can't upgrade to version 1.2 in order to try out D2X-XL or even face custom robots. I was wondering if there's any way to upgrade to version 1.2 without doing a clean reinstall and with the no-cd crack, as I don't think I'll be finding the CD anytime soon.

Alternatively, is there any way to get D2X-XL running with D2 version 1.1? (That's the version I'm stuck with.)

I've tried upgrading to version 1.2 with the no-cd crack on, as it seems the only file it won't patch is the EXE file, but when I tried installing and running D2X-XL, windows immediately gave me the error: D2X-XL has encountered a problem and needs to close. We are sorry for the inconvenience.

Posted: Mon Mar 31, 2008 8:12 pm
by Aus-RED-5
Hi Alter-Fox,

It's a shame you installed a nocd crack because D2x or XL does not require a crack to run D2.
They have switches/ CMD lines you can use to disable the CD.

Anyways. If you really want to solve your problems. Best thing to do is to just buy D2 again.
This way you can do all the clean fresh installs you want without complications. ;)

eBay 1
eBay 2
eBay 3
eBay 4
eBay 5 <---Infinite Abyss. Get this one.
eBay 6

Plus more.

Posted: Mon Mar 31, 2008 10:04 pm
by Sirius
If it's just the executable that doesn't patch, it makes me wonder if it's just something wrong with your D2X-XL installation. Have you tried using D2X 0.2.5/6, or if that doesn't work, D2X-Rebirth? If either will work it means it SHOULD be possible to get XL working.

Posted: Mon Mar 31, 2008 10:09 pm
by karx11erx
Maybe he simply couldn't be bothered to read and follow the installation instructions.

Posted: Wed Apr 02, 2008 7:15 pm
by Alter-Fox
I've almost got it working... I'm in the midst of figuring out which switches I need in the .ini file to get it to work. Any help would be appreciated.

Posted: Wed Apr 02, 2008 7:35 pm
by karx11erx
Try to run the win16 exe.

Posted: Wed Apr 02, 2008 7:39 pm
by Alter-Fox
I've tried running both the win16 and the other exe, neither of which have worked, but it has got farther into the program than it has before. I got it like this by trying different commands in the d2x.ini file. I'm just wondering if anyone could give me a list of what I need in there.

Posted: Wed Apr 02, 2008 8:18 pm
by karx11erx
The d2x.ini from the rar file contains useful settings.

Posted: Wed Apr 02, 2008 10:21 pm
by Alter-Fox
After reading the FAQ and trying several things to be sure, I've concluded that D2X-XL cannot find the D2 data... which is strange because it's all where it's supposed to be. I've put the path to the data folder in the .ini, but it still can't find it. The FAQ didn't have any information on how to fix this problem. If someone could help that would be greatly appreciated.

Posted: Wed Apr 02, 2008 10:57 pm
by karx11erx
The data has to be in the data subfolder.

Posted: Wed Apr 02, 2008 11:02 pm
by Alter-Fox
The data is in the data subfolder.

Posted: Thu Apr 03, 2008 12:29 am
by karx11erx
Post a support request on SF.net now please.

Posted: Thu Apr 03, 2008 1:07 am
by Alter-Fox
I just realized I was mistaken about the problem. I looked at d2x.log... it said there was a memory access violation. I'm still not sure how to fix it, but this might be a little easier.

Sorry for leading you in the wrong direction.

Posted: Thu Apr 03, 2008 6:55 am
by Aus-RED-5
Please post your system specs.

What CPU, MEM, Video Card and OS you have?

Make sure your video card and OS is up to date.
Same goes for D2X-XL versions.

Posted: Fri Apr 04, 2008 6:57 am
by Sirius
Create a support ticket at:
http://sourceforge.net/tracker/?group_i ... tid=797587
Be sure to include the specs RED-5 mentioned, and the entire contents of d2x.log. It'll help Diedel work out exactly where the problem is occurring.