Doors don't close, instead they spam their closing sound

Install & setup problems, application questions and other nasty things ;)

Moderators: Frustikus, simX, Aus-RED-5

User avatar
Vant Bray
Posts: 39
Joined: Sat Dec 15, 2007 2:38 am
Location: Planet Earth

Doors don't close, instead they spam their closing sound

Postby Vant Bray » Wed Jan 14, 2009 7:34 pm

Doors were working as intended until I updated my D2X to the newest version yesterday (it's been a while). Now they still open fine, but instead of closing they remain open and blare their closing sound. Not to mention, the sound is repeated really quickly over and over again like the door is trying to close but failing (which it is). I can still see through them and fly through them. I scoured the Configuration menu looking for anything regarding sound or doors or even textures that I thought could possibly fix it but didn't see anything.

I also downloaded the Enemy Within pack of levels and thought that might have something to do with it (since the only other thing I played was the first level of Descent 1, which only has one door that I didn't stick around to hear close (or not close)). But after I removed it no change.
User avatar
Aus-RED-5
Forum Moderator
Posts: 1490
Joined: Tue Sep 25, 2007 9:02 am
Location: Adelaide, South Australia
Contact:

Postby Aus-RED-5 » Wed Jan 14, 2009 9:31 pm

Try a fresh install of Descent2 and D2X-XL.

Create a NEW pilot profile too.
----System Specs----
Case: Corsair Obsidian 650D Black
Motherboard: ASUS Sabertooth X58
CPU: Intel Core i7 960 3.20ghz
Heat Sink: Corsair H100 CPU Water Cooler
Memory: Corsair 6GB (3 x 2048mb) DDR3 1600 Dominator (PC12800 - TR3X6G1600C8D)
Video Card: ATi SAPPHIRE Radeon HD 7970 3GB GDDR5 OC Edition
Hard Drives: SSD Corsair Force Series 3 F120 120GB & WD5003ABYX Enterprise RE4 500GB
Media Player: LG BH10LS30 BluRay Burner
Power Supply: Corsair HX-850
OS: Windows 7 Pro 64Bit
Monitor: Benq XL2420T LED
User avatar
Yokelassence
Posts: 971
Joined: Sun Apr 06, 2008 1:54 am
Location: That country full of sheep.

Postby Yokelassence » Wed Jan 14, 2009 10:33 pm

Is this with or without the hi-res door textures?
-Core i5 4690 3.5Ghz--GTX 1070 8GB--16GB DDR3 800--Z97 Extreme4--512GB SSD/2TB HDD--Zalman Z11 case-

Old PC that no longer turns on. May it R.I.P:
-Core 2 Duo E8500 3.2Ghz--HD4850 512MB--4GB DDR2-800--Gigabyte EP45-DS3L--640GB Storage--Antec 300 Case-
User avatar
Vant Bray
Posts: 39
Joined: Sat Dec 15, 2007 2:38 am
Location: Planet Earth

Postby Vant Bray » Thu Jan 15, 2009 3:39 am

Mm...I'm away from home and don't have the D2 installation discs with me at the moment, so no fresh D2 installs available for me. D:

I did a fresh install of D2X though and seem to have screwed it up more. I copied the "missions" and "data" folders (since I don't have a fresh D2 installation available) over to the new D2X folder and removed the old one. Doors still don't close, and additionally the only sounds being played are the music and the thrusters when I accelerate. I feel like a fresh D2 installation is more required than I was hoping.

I don't think I'm using hi-res door textures...How would I know?
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 5:44 am

I've been searching EVERYWHERE for a post about this! I have the exact same problem, except I never knew what it was. I thought some robot spawned inside of the wall or something, 'cause I could never locate where the sound was coming from, but this makes sense now. I have this same problem. It's a fresh install of D2 and 1, and it's definitely the doors. I do not have hires textures, and I have hires sounds off. I would really like this fixed, because it's horribly annoying.
User avatar
Pumo
D2X-XL Expert
D2X-XL Expert
Posts: 1437
Joined: Tue Sep 25, 2007 9:28 pm
Location: Here :)
Contact:

Postby Pumo » Fri Jan 16, 2009 6:34 am

If you're using 1.13.127 you will encounter several bugs on it. Wait for the upcoming 1.14 (maybe this weekend as Karx11erx/Diedel said) written on C++ and much more stable.
[Pumo software main website] - Pumo Mines current progress: 60%
-SYSTEM SPECS-
CPU: Intel Core i7 4790 3.6 GHz (4 GHz Turbo)
RAM: 16GB DDR3 1333MHZ
SSD: Kingston SSDNow V300, 240GB
HDD: Seagate 1TB 7200RPM SATA
External HDD: Seagate Backup Plus Slim 1TB 5400RPM
Video: nVidia GeForce GTX 1050 Ti OC 4GB
Sound: RealTek High Definition Audio
Display 1: LG 24M38H 24" 1080p HD LED Monitor
Display 2: Dell 19" 1440x900 TFT Monitor
OS: Windows 10 64-bits
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 2:27 pm

Also, Vant, the reason the sounds don't play aside from engine noises and such is because, by default, DLX-XL is installed with -hires_sound 1/2 in the dlx.cfg file. You must change it to 0 to allow non-hires sounds to play, and I would suggest shutting of hires sounds in-game, because the default ones don't sound very good on top of the normal sounds.
User avatar
Vant Bray
Posts: 39
Joined: Sat Dec 15, 2007 2:38 am
Location: Planet Earth

Postby Vant Bray » Fri Jan 16, 2009 3:46 pm

Thanks Pumo, I'll look for that coming up.

Sykes, thanks for that information. I changed the value to 0 but when I tried to test it I ran out of memory for the textures, even with them set to low. But I trust that it will work.

How much memory is required for the textures anyway?
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 4:14 pm

I just now downloaded all the hires stuff, so I havn't had memory problems yet, though I searched through every thread on this forum and I did run into some advice or this.

I read that if you add in -use_swapfile into d2x.cfg, then it will greatly increase the performance when running out of memory for textures. I havn't tried it myself though. Give it a try!
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 5:08 pm

So I got all the hires textures and installed them. I got the same problem as you, and I fixed it by lowering the texture quality in the render settings down to Medium instead of Highest. The installation guide recommends lowering it to High, but I had to go down to medium. I suppose the less textures you use, the easier it is on your computer. I used the -use_swapfile tag as well, by the way. I'm not sure what it did, though.

Also, I found a temporary fix for the door noise problem. Once you download and use all hires sounds, you can take some of them out. If you implement all hires sounds and turn them on using -hires_sound 1, then you can temporarily move the door close/sounds from the respective folder, so when it tries to play the sound, it can't find it, and it doesn't do anything. I will try to locate the specific sound files for this, as there is only one sound file that start with "door" so it's not easy to locate.

If anyone happens to know the specific WAV files of the "door closing" sound, it would be much appreciated.

Also, a note to the owner of this whole thing (my apologies, I forgot your name). You probably already know that the annoying crunching sound plays because the door is repeatedly trying to close and it can't, but I found another case in which this happened. I was playing a multiplayer game by myself just testing maps, and I was running into some odd glitches. Bullets were randomly stopping in mid air, and stayed that way. I then grabbed a 4-pack of merc missles, but I only had room for 2, so the 2 leftover missles were left in the air, and the models were colliding. It began to make that horribly assaulting "crunching" noise and wouldn't stop, even if I tried to pick up the missles again.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jan 16, 2009 5:28 pm

Sykes

==>
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 5:32 pm

Eeh, I'm sorry, what's the arrow supposed to point out? If I'm being annoying I can stop, but I have found the way to fix half of his problem!

There are 4 sound files per sound folder, their names are cldoor02, ddoorcl2, ddoorcl8, and vdoorcl5. Move them into completely different folders (make sure you leave the files from sound1 apart from the files from sound2). This will get rid of the door closing sounds completely, but it's not a big deal as doors don't close anyway.
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8112
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Postby karx11erx » Fri Jan 16, 2009 6:32 pm

It means read the links in my sig.

If I wanted to get rid of you I had better means than such an arrow. :P
User avatar
Sykes
Posts: 1120
Joined: Fri Jan 16, 2009 5:39 am
Location: Virginia, USA

Postby Sykes » Fri Jan 16, 2009 6:39 pm

I read them, but I'm not sure what I'm looking for :(
User avatar
Vant Bray
Posts: 39
Joined: Sat Dec 15, 2007 2:38 am
Location: Planet Earth

Postby Vant Bray » Fri Jan 16, 2009 11:33 pm

Lowering texture detail, changing -hires_sound to 0, and then adding -use_swapfile worked. Sounds are playing again. Doors are still not closing and being really loud though.

Removing those files did work as you said, but it'd be nice if they did close, haha. Accidentally opening doors and getting sniped by robots hiding behind doors that should be closed isn't too fun. :P

Return to “D2X-XL Help”

Who is online

Users browsing this forum: No registered users and 1 guest