Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lores"

Installationsprobleme, Anwendungsfragen und sonstige Schwierigkeiten

Moderator: Frustikus

Quix0r
Posts: 59
Joined: Sat Dec 15, 2007 10:05 am
Location: Krefeld, Germany
Contact:

Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lores"

Postby Quix0r » Sat May 21, 2011 12:56 am

Ich habe mich an die Anleitung fuer hires Schritt f. Schritt gehalten, dennoch scheint er wohl die lores-Bilder zu laden und die Szenerie bleibt schwarz (im "Rueckspiegel" kann man die Tuer hinter sich erkennen). Im Logbuch wird sehr haeufig "creating draw buffer" ausgegeben (630 mal!) Ich glaube auch deswegen habe ich eine niedrige FPS (teilweise unter 20 FPS).

Ich habe neueste Revision (du kannst immer HEAD annehmen).

Wenn das an Infos nicht reichen sollte, mache ich gerne ein Bug-Ticket auf.

Edit: Das mit losres ist normal, da keine hires vorhanden sind. Ich habe mal Descent2 (erster Level) gestartet, dabei ist mir weiteres aufgefallen:
- Die Animationen fuer neu hinzukommende Roboter "blinkt" schwarz, wenn die Animation durchgelaufen ist (zwischen letztem und ersten Frame ist eine ~100ms grosse schwarze Luecke)
- Die besagte Meldung "creating draw buffer" kam ueber 2.000 (!) mal vor,
- FPS sind oft unter 20 FPS, obwohl ich "-multithreaded 4" verwende und extrem niedrige Einstellungen (vieles aus sogar)
- Die Konfigurationsdateien ~/.d2x-xl/config/d2x-default.ini und /usr/local/games/d2x-xl/config/d2x-default.ini scheinen komplett ignoriert zu werden, ich hatte mal testweise eine andere Aufloesung in ~/.d2x-xl/config/d2x-default.ini eingetragen, da muesste eigentlich vor dem Laden des Pilotenprofils die Aufloesung sich entsprechend aendern, es tat sich aber nichts. -hires_foo 1 wurden somit auch komplett ignoriert

Ich erstelle dazu mal ein Bugticket. :)
OS: Debian Unstable AMD64, Kernel: 2.6.38.4
X: X.Org X Server 1.10.1
CPU: Intel Quad-Core 2.5 GHz
GPU: MSI GeForce 9500 GT, 512 MB
OpenGL: 3.3.0 NVIDIA 270.41.06
RAM: 8 GB (Markenspeicher, kein OEM)
Soundcard: Onboard Intel HD
SDL: 1.2.14
User avatar
IppoSenshu
Posts: 41
Joined: Sun Jul 04, 2010 2:57 pm

Re: Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lor

Postby IppoSenshu » Sun May 22, 2011 8:13 am

Schau dir mal die D2X-XL Switches der d2x-default.ini an. Du musst die Hires Texturen und Models zusätzlich in der Konfiguration aktivieren, sonst werden die alten benutzt. ;)
I'll never give up until the very end!
Quix0r
Posts: 59
Joined: Sat Dec 15, 2007 10:05 am
Location: Krefeld, Germany
Contact:

Re: Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lor

Postby Quix0r » Sun May 22, 2011 8:20 am

Das habe ich bereits, jedoch scheint die Datei ignoriert zu werden. Denn wenn ich die Parameter aus der Datei ~/.d2x-xl/config/d2x-default.ini alle manuell an das Binary d2x-xl uebergebe, werden alle HiRes-Texturen und Modelle geladen.

Das ist aber etwas OT und ich hatte das nur am Rande mit erwaehnt. :) Das Hauptproblem, dass die Texturen und Models nur im Rueckspiegel (Ruecksichtkamera) sichtbar und ansonsten alle Schwarz sind, ist noch nicht geloest.
OS: Debian Unstable AMD64, Kernel: 2.6.38.4
X: X.Org X Server 1.10.1
CPU: Intel Quad-Core 2.5 GHz
GPU: MSI GeForce 9500 GT, 512 MB
OpenGL: 3.3.0 NVIDIA 270.41.06
RAM: 8 GB (Markenspeicher, kein OEM)
Soundcard: Onboard Intel HD
SDL: 1.2.14
Quix0r
Posts: 59
Joined: Sat Dec 15, 2007 10:05 am
Location: Krefeld, Germany
Contact:

Re: Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lor

Postby Quix0r » Sun May 22, 2011 12:37 pm

Ich bin der festen Ueberzeugung, das die Szenerie wegen anderer Bugs schwarz bleibt und nicht wegen der fehlenden Texturen. Z.B. im Rueckspiegel (Rueckkamera) kann ich sehrwohl die Szenerie sehen, nach vorne raus aber nichts. Gerne lad ich einen Screenshot hoch.

@Diedel: brauchst du eventuell einen strace? Ich habe hier einen kompletten erstellt (jederzeit kein Problem).

VG,
Roland
OS: Debian Unstable AMD64, Kernel: 2.6.38.4
X: X.Org X Server 1.10.1
CPU: Intel Quad-Core 2.5 GHz
GPU: MSI GeForce 9500 GT, 512 MB
OpenGL: 3.3.0 NVIDIA 270.41.06
RAM: 8 GB (Markenspeicher, kein OEM)
Soundcard: Onboard Intel HD
SDL: 1.2.14
User avatar
karx11erx
D2X-XL Master
D2X-XL Master
Posts: 8111
Joined: Mon Sep 24, 2007 8:48 pm
Location: Wilferdingen, Germany
Contact:

Re: Levelszenerie bleibt schwarz, Logbuch zeigt "Loading lor

Postby karx11erx » Sun May 22, 2011 1:04 pm

Liest Du eigentlich keine Antworten auf Deine Bug-Tickets?

Du hast mit einer Entwicklungsversion des Quellcodes gearbeitet und sollst bitte warten, bis das nächste Release rauskommt.

Return to “D2X-XL Hilfe”

Who is online

Users browsing this forum: No registered users and 1 guest